objectscriptQuality 3.3.2

SonarQube compatibility

9.5, 9.4, 9.3, 9.2, 9.1, 9.0, 8.9 (LTS), 8.8, 8.7, 8.6, 8.5, 8.4, 8.3, 8.2, 8.1, 8.0, 7.9 (LTS), 7.8, 7.7, 7.6, 7.5, 7.4, 7.3, 7.2

IRIS compatibility

2022.1, 2021.2, 2021.1, 2020.4, 2020.3, 2020.2, 2020.1, 2019.1, 2018.1

Ensemble compatibility

2018.1, 2017.2, 2017.1, 2016.2, 2016.1, 2015.2, 2015.1, 2014.1

Caché compatibility

2018.1, 2017.2, 2017.1, 2016.2, 2016.1, 2015.2, 2015.1, 2014.1

Java compatibility

Oracle JDK 11, Oracle JDK 8

Release notes

Since version 3.0.0 we have renamed our product to fit better the target language analyzed: ObjectScript. We have also renamed all the related products like objectscriptQuality for Caché Studio, objectscriptQuality for Aterlier and objectscriptQuality for VSCode.

Since version 3.3.0 we have removed support for SonarQube previous to version 7.0.

Fixes

  • fix when used in kubernetes with helm