Avoid using short names for system functions

objectscriptQuality release 
1.0.0
Id 
OS0005
Rule type 
Code Smell
Severity 

Info

Info
SQALE characteristic 
  • Maintainability
    • Readability
Tags 
coding-guidelines, confusing
Remediation function 
Constant/issue
Remediation cost 
5min

Many ObjectScript system functions have a short name in addition to their regular name.

However, using these short names can be confusing, especially for new developers, and harm code readability.

Therefore, instead of writing:

    set x = $zdt($horolog)

it is advised to write:

    set x = $zdatetime($horolog)